Android 14 заблокирует установку приложений для старых версий Android и APK-файлов

→ Оригинал (без защиты от корпорастов)

Так Google планирует сдержать распространение зловредов

Как сообщает 9to5google, ссылаясь на разработчиков, в операционной системе Android 14 будут ужесточены требования: компания Google по умолчанию заблокирует установку устаревших приложений. Кроме того, грядущее изменение заблокирует загрузку определённых APK-файлов пользователями.

Первоначально устройства Android 14 будут блокировать только приложения, предназначенные для самых старых версий Android. Однако со временем планируется повысить порог до Android 6.0 (Marshmallow), при этом Google постепенно может поднимать планку и дальше.

Однако есть вероятность, что каждый производитель устройств будет решать, какой порог для устаревших приложений должен быть включён и будет ли вообще включён. Если функция будет активна, то на конкретном устройстве нельзя будет устанавливать приложения для устаревших версией Android.

Блокируя эти устаревшие приложения, Google намеревается сдержать распространение вредоносных программ на Android. Разработчик, ответственный за изменение, подтверждает, что некоторые вредоносные приложения намеренно нацелены на более старые версии Android, чтобы обойти определённые средства защиты, применяемые только к более новым приложениям.

Однако, как уточняет разработчик, если вы решите, что вам нужно установить устаревшее приложение, сделать это всё равно будет возможно.

Релиз Android 14 ожидается в этом году.